Menu
EtoileAbonnementRSS
jeuxvideo.com  /  Tous les forums  /  Forum principal Informatique  /  Forum Linux  / 

Topic Xubuntu ne demarre plus en mode graphique !!?

Sujet : Xubuntu ne demarre plus en mode graphique !!?

1
Cocorico7575
Cocorico7575
MP
02 janvier 2021 à 15:22:46

bonjour, j ai un pc avec Xubuntu, pendant 1 an je n avais aucuns soucis . cependant aujourd hui depuis que j ai cree une deuxiemme session(utilisateur) et l installation de vmware avec l iso win 10 + ayant fait une maj de l appli logiciel : Après le démarrage et chargement de xubuntu, j'ai directement une console terminal pour inscrire mon login (à la place d el'interface graphique login) : je n arrive plus à acceder à la session de login en interface graphoque et du coup ni au bureau etc...

ci joint capture d ecran.
https://ibb.co/tBR3Q2G
https://ibb.co/nnDnMNK
https://ibb.co/fX3tb7Z
https://ibb.co/vJVzBmt
https://ibb.co/M235x6J
https://ibb.co/ScfRN1Y
https://ibb.co/tYmJPyw
https://ibb.co/KqyzMLT
lorsque que je lance startx ou install dektop au reboot je n'ai rien de changé.

Merci

Eklaes
Eklaes
MP
02 janvier 2021 à 18:23:36

Bonsoir,
Pourrais-tu poster le contenu du fichier Xorg.conf situé dans /etc/X11 ?
Sur certaines de tes pièces jointes, il y a une erreur de configuration relative à ce fichier.

Cocorico7575
Cocorico7575
MP
02 janvier 2021 à 19:41:59

Salut Eklaes je ne maitrise pas UBUNTU et encore moins le terminal, saurais la ligne de commande qui permet de lire ce fichier stp ?
À moins que je puise le visualiser dans mon HDD à l'aide de la session en live usb

Merci :)

Eklaes
Eklaes
MP
02 janvier 2021 à 19:48:20

Bien entendu. Tu as juste à démarrer ta distribution (de manière classique sans livecd), te connecter et de saisir la commande suivante :
cat /etc/X11/xorg.conf
Tu pourras ensuite photographier ton écran.

Cocorico7575
Cocorico7575
MP
04 janvier 2021 à 00:33:05

Salut eklaes,
J'ai tappé la comande par contre dans le résultat affiché je ne sais oas si j'ai accès à tout car je n'ai pas l'option de scroll en haut(remonter en haut ) : voici le résultat :
https://ibb.co/SvHMJWT

Kolzan
Kolzan
MP
04 janvier 2021 à 00:55:18

Utilise plutôt nano pour scroller.

nano /etc/X11/xorg.conf puis ctrl+X pour quitter (une fois que t'as pris les photos).

Cocorico7575
Cocorico7575
MP
06 janvier 2021 à 00:47:41

Salut bah du coup en tapant la commande nano j'ai toutes ces indications : https://ibb.co/3Rxkfb8

Mais je n'arrive pas à scroler la réponse de commande cat /etc/X11/xorg.conf

deepblue
deepblue
MP
06 janvier 2021 à 14:27:07

Oula, y'a un sacré bordel dans ce fichier. Il y a des commentaires qui sont passé en instruction de configuration et ça casse le démarrage de xorg. Tape ces commandes stp :

sudo -i
cd  /etc/X11/
grep -v "\.$" xorg.conf > xorg2.conf
cat xorg2.conf
  • la 1ère commande te passe en root
  • la 2ème commande permet de te déplacer dans le répertoire /etc/X11
  • la 3ème commande récupère le contenu de "xorg.conf" et "masque" les lignes que termines par un "." (les commentaires terminent pas un point d'après ce qu'on voit). Le résultat est redirigé dans un nouveau fichier "xorg2.conf"
  • la 4ème commande affiche le contenu de "xorg2.conf"
Message édité le 06 janvier 2021 à 14:29:28 par deepblue
Cocorico7575
Cocorico7575
MP
08 janvier 2021 à 09:50:58

Ah je vois deep blue. Je fais ça tout talheur et je vous tiens au jus. En tout cas merci encore

Cocorico7575
Cocorico7575
MP
08 janvier 2021 à 11:03:36

Bonjour c'est fait voici les captures d'écran j'en ai fait plusieurs pour être sûr que ce soit visible.
https://ibb.co/2WQ7NWY
https://ibb.co/Q6sJ3ny
https://ibb.co/BGrwq3s
https://ibb.co/MfTr4x9

Eklaes
Eklaes
MP
08 janvier 2021 à 18:05:10

Bonsoir,

Avant toute modification, effectue une sauvegarde de ton xorg.conf original (mv équivaut à un couper/coller, cp à un copier/coller) :
sudo mv /etc/X11/xorg.conf /etc/X11/xorg.conf.original

Ton fichier a été bien nettoyé avec les indications données par deepblue, mais il reste 2 lignes à supprimer. Tu as juste à éditer le fichier /etc/X11/xorg2.conf avec la commande "sudo nano -w /etc/X11/xorg2.conf" puis à supprimer les deux lignes suivantes :

Specify the mouse protocol. Valid protocol types include:
Enable/Disable the emulation of the third (middle) mouse button for mice which only have two physical buttons. The third button is emulated by pressing both buttons simultaneously. Default: off

Une fois supprimées, presse les touches Ctrl+X puis Entrée.
Tu dois ensuite remplacer ton xorg.conf initial par celui que tu as modifié avec la commande :
sudo cp /etc/X11/xorg2.conf /etc/X11/xorg.conf

Tu peux ensuite conserver une copie de sauvegarde de ce fichier (en cas de pépin) avec la commande suivante :
sudo mv -v /etc/X11/xorg2.conf /etc/X11/xorg.conf.bak

Redémarre ensuite ton pc et tiens-nous informés si la modification proposée par deepblue fonctionne.

Message édité le 08 janvier 2021 à 18:06:11 par Eklaes
Cocorico7575
Cocorico7575
MP
12 janvier 2021 à 13:06:00

Eklaes merci oour ta rep. Dsl pour mon retard.

J'ai bien essayé mais je ne sais pas comment supprimer les lignes dont tu me parles ni comment même les voir :
https://ibb.co/pRDNjs0
https://ibb.co/z6ddrh4

Eklaes
Eklaes
MP
12 janvier 2021 à 14:04:19

Dans toutes les commandes de mon message, la casse (les minuscules/majuscules) doit être respectée. Il est donc normal en saisissant "Xorg.conf" au lieu de "xorg.conf" que la commande ne puisse trouver un fichier qui n'existe pas. Reessaye en suivant ce principe, et les commandes aboutiront.

1
Répondre
Prévisu
?
Victime de harcèlement en ligne : comment réagir ?