Les forums de JeuxVideo.com Liens NoelShack : Texte / Image Taille des forums : Normale / Large

Forum : Minecraft

Ajouter ce forum à mes forums préférés Ajouter ce forum à mes forums préférés

Fiche de jeu : PS4 | ONE | PS3 | 360 | Vita | Web

Sujet : « Probleme plugin Permission/Essentials »

Créer un nouveau sujet   Liste des sujets
Alerte mail  Répondre  Rafraichir
  • Toxxik512 Voir le profil de Toxxik512
  • Posté le 8 mars 2011 à 16:28:30 Avertir un administrateur
  • Bonjour à tous,
    j'ai récemment installé le plugins Essentials sur mon serveur privé Minecraft ainsi que le plugins Permissions.
    Sauf que, je me suis rentré dans le plugin Permission en tant qu'admin et j'ai mis '*' pour avoir tous les droit , mais pour les joueurs que je veux mettre en Default, je leurs ai accordé certaines commandes mais ils ne peuvent pas les utiliser. Un méssage s'affiche "You don't have the permission....." pourtant j'ai rentré tout leurs droit un part un dans la catégorie Default -> permission -> - 'essentials.help' et autres les uns en dessous des autres comme indiqué sur certains tuto.
    Apres dans la catégorie Users , j'ai mis leur pseudo ainsi que dans group: Default et dans permission jai retapé toute la liste des commandes.
    Mais en jeu cela ne marche toujours pas, et si je les rentre dans ops.txt cela leur donne tous les droit.
    Voila , si vous voulez des screens je peux vous en mettre, merci d'avance.
    J'espère avoir bien expliqué.

    Bon jeu à tous
  • Lien permanent
  • lohengrin77 Voir le profil de lohengrin77
  • Posté le 8 mars 2011 à 16:34:30 Avertir un administrateur
  • ah pas tu tombe bien. j'ai laissé tombé permission quand j'ai mi essentials, au profit de groupmanager (il simule permission, tu peux metre les plug nécessitant permission^^).
    post ton yml stp qu'on voit si c'est un probleme de node.

    sinon regarde si les espaces sont correct, que ya pas de tabulation et que t'es bien en utf8.
  • Lien permanent
  • lohengrin77 Voir le profil de lohengrin77
  • Posté le 8 mars 2011 à 16:53:27 Avertir un administrateur
  • ban je prend le risque d'upper ton topic. c'est pas essentials.help que tu touche c'est essentials.yml.

    pour les permission c'est le config.yml dans le dossier permission, et si mes souvenirs sont bon, tu doit le remomer du nom de ton monde (wordl.yml si t'as pris un monde par defaut).
    mise à par la tabulation et le respect scrupuleux des espace. je voit pas grand chose qui plante les permissions.
    as tu un message d'erreur au chargement du plugin (console)
    t'as quelle version de permission? de bukkit?
    ton groupe Default t'es sur que c'est pas default?
    tu met bien? :
    - essentials.help
    - -essentials.god

    pour limiter le pékin moyen ne fait:
    - -essentials.*
    - essentials.tout ce que tu autorise
    - essentials.tout ce que tu autorise
  • Lien permanent
  • lohengrin77 Voir le profil de lohengrin77
  • Posté le 8 mars 2011 à 16:54:45 Avertir un administrateur
  • youpi triple post vivement "éditer"

    désolé pour essentials c'est config.yml
  • Lien permanent
  • Toxxik512 Voir le profil de Toxxik512
  • Posté le 8 mars 2011 à 17:02:59 Avertir un administrateur
  • Voila mon fichier config.yml http://www.mediafire.com/?sa2aq5pp05k9m95

    Je précise que mon serveur tourne sous Ubuntu, mais ca ne change pas grand chose normalement.
    Et je comprend pas pourquoi il faut mettre deux " - " devant essentials.god , ah oui et je n'ai pas essentials.god car dans le jeu je n'ai pas la commande /god ni /heal je crois.

    Je n'ai pas de messagge d'erreur et j'ai installé la derniere version de bukkit ( je l'ai installé hier ) j'ai pris le dernier recommandé par le site bukkit.
  • Lien permanent
  • Toxxik512 Voir le profil de Toxxik512
  • Posté le 8 mars 2011 à 17:05:42 Avertir un administrateur
  • Sinon le plus simple serai d'installer le plugin GroupManager au lieu de Permission ?
  • Lien permanent
  • lohengrin77 Voir le profil de lohengrin77
  • Posté le 8 mars 2011 à 17:12:04 Avertir un administrateur
  • bah depuis que j'ai eu mon probleme j'ai beaucoup apris sur les permissions, puis permission est devenu obselete, puis groupmanager est devenu courant, puis une nouvelle version performante de permission est sortie, mais j'ai gardé GM puisque j'ai aucun souci avec. je regarde ton yml et je te dis.
  • Lien permanent
  • lohengrin77 Voir le profil de lohengrin77
  • Posté le 8 mars 2011 à 17:16:23 Avertir un administrateur
  • je voit qq erreur, la plus grosse étant que le plugin general est incompatible vec essentials vire general et va cherche le plug tele (ou tp) d'essentials.

    regarde ici pour les node correctes.
    http://ess.earth2me.com/index.php/Command_Reference

    je te post un yml corrigé
  • Lien permanent
  • lohengrin77 Voir le profil de lohengrin77
  • Posté le 8 mars 2011 à 17:26:05 Avertir un administrateur
  • essaye ça http://www.mediafire.com/?fqz80e73dehrmrs


    au passage pas besoin de définir les permission individuellement pour chaque joueur, t'as juste à metre à quel groupe ils appartiennent, et t'as pas de moderator...
  • Lien permanent
  • lohengrin77 Voir le profil de lohengrin77
  • Posté le 8 mars 2011 à 17:28:24 Avertir un administrateur
  • pff wtb "éditer"

    et warp j'ai oublié setwarp dans les perm de default, met le s'il n'y ai pas et regarde la forme c'est
    - essentials.setwarp


    pas de ''
  • Lien permanent
  • Toxxik512 Voir le profil de Toxxik512
  • Posté le 8 mars 2011 à 18:27:39 Avertir un administrateur
  • Merci pour m'avoir corrigé le fichier. Je le teste immédiatement.
    Je te dis si ca marche.
    En tout cas merci beaucoup de m'aider
  • Lien permanent
  • Toxxik512 Voir le profil de Toxxik512
  • Posté le 8 mars 2011 à 18:35:30 Avertir un administrateur
  • Merci beaucoup !!! lohengrin77
    Ca marche impec' !

    :D
  • Lien permanent
  • lohengrin77 Voir le profil de lohengrin77
  • Posté le 8 mars 2011 à 19:25:40 Avertir un administrateur
  • plaisir d'offrir. si t'as de probleme mp directement, je suis pas mes réponses.


    sinon pour vanter les mérite de groupmanager, t'as pas besoin d'éditer le fichier pour chaque nouveau membre, tu les promeux ingame et le plug se charge de s'en souvenir, c'est plutot chouette, chose qui était bancale sur permission, puis coupé (/modgrp etc) et la je sais pas si c'est réparé.
  • Lien permanent
  • Deathdarkangel Voir le profil de Deathdarkangel
  • Posté via mobile le 8 mars 2011 à 19:28:06 Avertir un administrateur
  • Alors moi j'aurai aimé savoir comment pouvoir changer le statut des joueurs directement en ligne. Je sais que c'est possible mais je ne trouve pas la commande a utiliser ou le plugin a installer. Merci d'avance
  • Lien permanent
  • lohengrin77 Voir le profil de lohengrin77
  • Posté le 8 mars 2011 à 19:37:54 Avertir un administrateur
  • les commandes dépendent du plugin. sur permission go forum bukkit.

    sur gm c'est /manpromote joueur groupe
  • Lien permanent
  • deathdarkangel Voir le profil de deathdarkangel
  • Posté le 8 mars 2011 à 20:12:25 Avertir un administrateur
  • Ok merci beaucoup, GM donne les meme possibilité que permissions et il est plus simple a utiliser ?
  • Lien permanent
  • Toxxik512 Voir le profil de Toxxik512
  • Posté le 8 mars 2011 à 20:55:31 Avertir un administrateur
  • Sur permission je suis pas sur que ce soit possible, pour l'instant je garde permission mais je changerai surement pour GM , mais pour l'instant je vais profiter un peu de mon serveur :)
    Merci encore
  • Lien permanent
Alerte mail  Répondre  Rafraichir

Sujet : « Probleme plugin Permission/Essentials »

Créer un nouveau sujet   Liste des sujets

Flux RSS du sujet "Probleme plugin Permission/Essentials"

Toutes les infos du jeu Minecraft sur : Minecraft sur PlayStation 4 Minecraft sur Xbox One Minecraft sur PlayStation 3 Minecraft sur Xbox 360 Minecraft sur PlayStation Vita Minecraft sur Web

Les vidéos à la une